Recent comments

Rossonero's picture

Whish I could help but it's probably not an nVidia related problem since I use nVidia :)
GTX 550 Ti and Driver version 337.25.
My guess is that you are missing some 32-bit libs

Pic's picture

I won't start for me with nVidia 650m.

Rossonero's picture

It's not perfect on Linux but it's absolutley playable. Have mostly experienced minor graphical glitches and some painful random loadingtimes.

nullzero's picture

Its one of the few games where some of the more humble GPU cards are not even supported. So maybe the requirements are a bit steep. I've an Intel so I should probably not buy it to just find out latter that it doesn't work :(

Also... while the game has a 95% score in steam, half of the bad reviews are "the game is broken in mac..." but it doensn't (yet?) work well in Linux too. Can anyone confirm?

Azmond's picture

I'm not on this thing often enough to be a maintainer, have a enough crap as it's going on. xD But i'll do what i can.

pheonton's picture

Rimworld. Which i'm suprised wasn't added in the See also list.
psst... please go ahead and add it.

pheonton's picture

Have you tried our new game listing yet? We recently opened up all possibilities (nearly):
http://www.lgdb.org/games/advanced

fastrgv's picture

Yes, I'd like to merge them. Also Seven and SevenAda.